Welcome, Guest. Please Login.
02/21/18 at 04:19:41
News:
Home Help Search Login


Pages: 1
Send Topic Print
Deposit stuck on Open Customer report (Read 118 times)
gtladmin
Active Member
*****


Diving is fun,
diving is fun!

Posts: 1195
Gender: female
Deposit stuck on Open Customer report
02/01/18 at 11:26:34
 
Forwarding from our accounting manager:
 
"I have a customer's deposit that is stuck on the Open Customer Deposits report as a "customer not found". It belongs to Gentex (code GENCORP). I looked up the customer code & it has not been deleted (or archived).
 
The payment would have been done under AR-C & listed as a "deposit on account" prior to posting it; which is not something new. We actually enter deposits on account through AR-C when it is included in a batch deposit (such as credit card payments). If it's a single customer deposit (such as a wire transfer or EFT), we will enter them through AR-N directly.
 
This issue is causing the Accounts Receivable aging to not coincide with the balance sheet. The difference is exactly the amount of the deposit in question.
 
Can we find out how this can be fixed? Does it need a maintain database? As you can see from one of the attachments, I am unable to edit the transaction in AR-N and there is no way to reverse it without an account code. I am pretty sure that deleting it from AR-N (if it allowed me to) would make the issue worse."
 
Also she mentions:  "The customer has been invoiced for the order, but it is the only thing on their account. The deposit is the full payment for the order, but I am unable to connect the two."
And when asked if it is attached to a SO she replies "No, I am unable to attach it to a Sales Order because of it's status. I usually have to do that after the fact by editing the deposit."
 
Any suggestions on how I fix this for her?
 
Kind regards,
 
Val
Back to top
 
 

Val Feehan
Evo version 2017.2, Build 06/23/17 T7-7i R11
Pervasive 11.31 (Pervasive SQL 11 SP3)
OES 11 SP2/SuSE Linux 11 SP4 client/server

WWW   IP Logged
prophet
Member
**




Posts: 95
Re: Deposit stuck on Open Customer report
Reply #1 - 02/01/18 at 12:48:49
 
I don't see any attachments, that being said, you mentioned you can AR-N and not being able to edit it. So does that mean it is showing up on AR-N?
Back to top
 
 
  IP Logged
gtladmin
Active Member
*****


Diving is fun,
diving is fun!

Posts: 1195
Gender: female
Re: Deposit stuck on Open Customer report
Reply #2 - 02/02/18 at 12:07:42
 
sorry, I don't have any external location to post attachments she provided to me. But to answer the question, as she states yes she does see it in AR-N but is unable to edit it.  Holly says " am unable to edit the transaction in AR-N and there is no way to reverse it without an account code. I am pretty sure that deleting it from AR-N (if it allowed me to) would make the issue worse."  
 
Any ideas?
Back to top
 
 

Val Feehan
Evo version 2017.2, Build 06/23/17 T7-7i R11
Pervasive 11.31 (Pervasive SQL 11 SP3)
OES 11 SP2/SuSE Linux 11 SP4 client/server

WWW   IP Logged
Lynn_Pantic
Administrator
*****


evolution (n) -
gradual change to a
different form

Posts: 5558
Re: Deposit stuck on Open Customer report
Reply #3 - 02/02/18 at 14:02:25
 
The files involved that you may need to edit in Maintain Database to get it attached back to the account so it cal be applied to the invoice are BKARINVT, BKARDEP and possibly BKART
Back to top
 
 

Lynn Pantic
IS Tech Support
lynn@istechsupport.com
Email   IP Logged
gtladmin
Active Member
*****


Diving is fun,
diving is fun!

Posts: 1195
Gender: female
Re: Deposit stuck on Open Customer report
Reply #4 - 02/08/18 at 14:22:43
 
Ok, I will try to get a moment and look at those.  Thanks!  Will let you know.
 
Val
Back to top
 
 

Val Feehan
Evo version 2017.2, Build 06/23/17 T7-7i R11
Pervasive 11.31 (Pervasive SQL 11 SP3)
OES 11 SP2/SuSE Linux 11 SP4 client/server

WWW   IP Logged
gtladmin
Active Member
*****


Diving is fun,
diving is fun!

Posts: 1195
Gender: female
Re: Deposit stuck on Open Customer report
Reply #5 - 02/08/18 at 15:45:31
 
Ok, looked at the 3 tables and here's what I see:
 
BKARINVT = 3 records for this customer.  Two are for corresponding amounts 507.00 and -507.00 (payment).  The 3rd record is for a positive amount, 452.00. No corresponding payment record.
 
BKARDEP = no records listed for this customer. 6 records in the table, one has a deposit # and a date, but nothing else.  
 
BKART = 3 records for this customer.  Same as BKARINVT.
 
What do I do to "get it attached back to the account"....?
 
Kind regards,
 
Val
Back to top
 
 

Val Feehan
Evo version 2017.2, Build 06/23/17 T7-7i R11
Pervasive 11.31 (Pervasive SQL 11 SP3)
OES 11 SP2/SuSE Linux 11 SP4 client/server

WWW   IP Logged
Lynn_Pantic
Administrator
*****


evolution (n) -
gradual change to a
different form

Posts: 5558
Re: Deposit stuck on Open Customer report
Reply #6 - 02/09/18 at 09:23:04
 
The point (as I understand it) is that this deposit is NOT attached to the customer so the customer code in the record is blank and needs to be edited.
Back to top
 
 

Lynn Pantic
IS Tech Support
lynn@istechsupport.com
Email   IP Logged
gtladmin
Active Member
*****


Diving is fun,
diving is fun!

Posts: 1195
Gender: female
Re: Deposit stuck on Open Customer report
Reply #7 - 02/12/18 at 11:52:59
 
Thanks, just need to be sure, nothing like FUBARing Evo by editing the wrong DB.  Wink
 
So, I will try to edit the BKARDEP table in a test company, adding in the customer code and see if that helps Holly, and then do it in the real company.
 
Thanks for the help.
Back to top
 
 

Val Feehan
Evo version 2017.2, Build 06/23/17 T7-7i R11
Pervasive 11.31 (Pervasive SQL 11 SP3)
OES 11 SP2/SuSE Linux 11 SP4 client/server

WWW   IP Logged
gtladmin
Active Member
*****


Diving is fun,
diving is fun!

Posts: 1195
Gender: female
Re: Deposit stuck on Open Customer report
Reply #8 - 02/13/18 at 15:07:09
 
Problem solved: In our test company, I backed up then edited the BKARDEP table via Maintain DB and added the customer code to the record where it was missing. Then I let the accounting manager know, and she went in to attached the deposit.  Only issue was the sales order had already been invoiced and closed.  So she tried some thing (and I may be missing some steps in what she told me) where she re-opened the sales order, entered a random dollar value, released the order, posted the invoice, applied the payments and then credited the dummy invoice and now everything balances.  
 
So we did the same thing in the production company and same result, the issue is resolved.
 
Thanks for the help!
 
Val
Back to top
 
 

Val Feehan
Evo version 2017.2, Build 06/23/17 T7-7i R11
Pervasive 11.31 (Pervasive SQL 11 SP3)
OES 11 SP2/SuSE Linux 11 SP4 client/server

WWW   IP Logged
Pages: 1
Send Topic Print